PAN1026 Deep Sleep Mode problem

Hello,

I’m writing to you regarding an issue with PAN1026 deep sleep mode set up, and I’m hoping you can shed some light on it. 
I am trying to put PAN1026 to sleep mode when it’s not connected, I must do it using UART comands (not GPIO0). I used several methods, first - I used command TCU_MNG_INIT_REQ and TCU_MNG_DEEP_SLEEP_REQ. This is how I set up:
1. hw_reset
2. Switch to TCU mode by HCI_SET_MODE request
3. TCU_MNG_INIT_REQ
4. TCU_MNG_DEEP_SLEEP_REQ (this command does not return status, don't return nothing)

second - I tryed  nex command:
1.  M2 _BTL_SET_DEEP_SLEEP (During HCI mode)
2.  TCU_MNG_INIT_REQ 
3.  TCU_MNG_LE_INIT_REQ 
4.  Start advertising 
5.  Start advertising or get connected.
6. Send TCU_MNG_DEEP_SLEEP_REQ (this command does not return status, don't return nothing)

TCU_MNG_DEEP_SLEEP_REQ:
  uint8_t tsu_mng_deep_sleep_req[] =
{ 0xe1, 0xb6,          // ServiceID, OpCode
  0x01, 0x00,          // Parameter Length
  0x01                    //deep sleep mode enable
 };
 

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • You must use M2 _BTL_SET_DEEP_SLEEP in HCI mode to configure the sleep mode otherwise it will not be used later in TCU mode, so your second attempt is correct.

    You can send the device to sleep later using TCU_MNG_DEEP_SLEEP_REQ.

    However, no Bluetooth Low Energy connection is allowed and a Bluetooth Classic connection must be in sniff mode.

    As a response you should receive TCU_MNG_DEEP_SLEEP_RESP.

    If this is not working for you, please check the status code of TCU_MNG_DEEP_SLEEP_RESP.

    Is it 0x00 which indicates success or does it indicate a problem?

    Like
Like Follow
  • Status Answered
  • 2 yrs agoLast active
  • 1Replies
  • 175Views
  • 2 Following